Gardening Know How Questions & Answers - https://questions.gardeningknowhow.com

weigela hasn’t bloomed

I planted weigelas 2 years ago and they still haven’t bloomed. They look healthy and are growing, but no flowers. What should I do?


1 Comment (Open | Close)

1 Comment To "weigela hasn’t bloomed"

#1 Comment By theficuswrangler On 07/24/2014 @ 8:30 pm

Several things can keep a plant from flowering. Youth, for one — sometimes plants don’t flower until they’re several years old. Too much shade is another. The third most likely is too much nitrogen/too little phosphorous. The fix for the first is patience; the second is hard, unless you can cut back some limbs; the third involves cutting back on fertilizer, using fertilizer with a higher middle number, and working bonemeal into the soil as an immediate fix.


Article printed from Gardening Know How Questions & Answers: https://questions.gardeningknowhow.com

URL to article: https://questions.gardeningknowhow.com/i-planted-wieglias-2-years-ago-and-they-still-havent-bloomed/

Have any questions about this topic? Visit us at https://questions.gardeningknowhow.com to ask your questions and get friendly answers from gardening experts.

You can also find us at:
'Like' us on Facebook: https://www.facebook.com/gardeningknowhow
Follow us on Twitter: https://twitter.com/gardenknowhow - @gardenknowhow
Follow us on Pinterest: https://pinterest.com/gardenknowhow/

Copyright © 2019 Gardening Know How Questions & Answers. All rights reserved.